October 19th, 2006

magikist

(no subject)

I just downloaded Internet Exploder release 7 from the Microsoft website. It still sucks. In fact, it managed to lock up my computer so badly that I had to reboot. Plus, when I try to use a website at the office that requires IE, the application says "Must use Internet Explorer 5.5 or above". Uh, last time I looked, 7 was greater than 5.5....

Don't waste your time. I'm sticking with Firefox wherever I can.
magikist

(no subject)

Read, please, and understand why I'm going straight elephant on Nov 7.

My favorite line?

Given that the richest member of the House is also a Democrat and the three richest senators are all Democrats, I get a chuckle any time a liberal refers to Republicans as the party of the rich.